#3640 PhotoBooster & PhotoEngine Q&A


Q: When I check the PhotoEngine Plug-in from a Power Macintosh, Photoshop 2.5.1 indicates that the computer is a 68020. Why?

A: The indication of a 68020 processor is correct. The emulator on the Power Macintosh is emulating a 68020, and since Photoshop 2.5.x is not native to the Power Macintosh, the 68020 emulation mode will be engaged. Only Photoshop 3.0 will use native Power Macintosh code.

Q: How do I know if the PhotoEngine is actually working?

A: The best way to verify that the PhotoEngine is operating is to open the computer and watch the 4 LEDs that are located just to the left of the metal strip on the top of the board. They are marked DS0, DS1, DS2, and DS3. You can also make a green dot appear in your menu bar each time the PhotoEngine's DSPs are accessed by opening the about box for the PhotoEngine Plug in. To do that, launch Photoshop and select the menu choice entitled "About Photoshop Plug-ins" from under the Apple menu in the upper left hand corner of your screen, then drag to select the PhotoEngine plug in. When the About box appears, hold down the key labeled Option on your keyboard and click in the center of the dialog box. This will cause a green dot to appear in your menu bar when the DSP are accessed. To turn off the dot, repeat the previous steps.

Q: What's the difference between PhotoBooster and PhotoEngine?

A: The PhotoEngine is a NuBus card with 4 DSPs (Digital Signal Processors) and will work with any Macintosh that has an available NuBus Slot. The PhotoBooster is a PDS (Processor Direct Slot) card with 2 DSPs, and requires a free PDS slot to operate. Some machines that have a PDS are the Quadra or Centris 650, Quadra 800, Quadra 900, Quadra 700 and the Quadra 950.

Q: Does the PhotoEngine software run in the native mode on a Power Macintosh?

A: The PhotoEngine software as well as the PhotoEngine INIT run in native mode. Also, Photoshop 3.0 is native, but Photoshop 2.5.1 is not.

Q: Is the PhotoEngine and PhotoBooster software 7.5 compatible?

A: Yes, the software is 7.5 compatible.

Q: Is the PhotoEngine and PhotoBooster compatible with Photoshop 3.0?

A: Yes, the software is compatible with Photoshop 3.0.

Q: I have PhotoEngine, and Photoshop 3.0 keeps telling me that the PhotoEngine has detected an error and will not function until restart. I keep restarting and getting the same message, Why?

A: PhotoEngine software has been found to give this message when the computer has more than 200 MB of memory installed. Radius is working on a new version of the software to correct this which will be available soon.

Q: Can you run the PhotoEngine and the PhotoBooster together in the same computer?

A: You could run both boards in the same computer, but there would be no advantage. The PhotoEngine is faster than the PhotoBooster and handles all of the same filters.

Q: Will the PhotoEngine and the SuperMac Thunder II GX card run together and give you acceleration from both boards?

A: The Thunder II series of cards are compatible with the PhotoEngine. However, the acceleration for Photoshop is greater with the PhotoEngine than with the Thunder II GX cards. The IPA (Image Processing Acceleration software) will have to be removed. The QuickDraw acceleration will still function fine.

Q: How much acceleration will I see with the PhotoEngine installed?

A: With Photoshop 2.5.1 or 3.0 you will see dramatic increases in performance using PhotoEngine. For example, on a Power Macintosh performing a Gaussian Blur on an Image using a radius of 2, PhotoEngine is about 4.5 time faster than the Power Macintosh. Results are even more dramatic when PhotoEngine's speed is compared to Macintosh Quadra, Centris or Mac II series of computers.

Q: What are the current versions of the software I need to use a PhotoEngine, and how can I obtain it ?

A: You need a total of two files to use a PhotoEngine. The first file is a System Extension entitled "•Radius DSP" which should be placed in the Extensions folder of your System folder. The current version of that file is 2.0. The second file is a Photoshop Plug-in, entitled "PhotoEngine Plug-in" which should be placed into the folder you are using to contain your Photoshop Plug-ins. The current version of the Plug-in is 1.0. If you do not have the current versions of the necessary software , they can be obtained for free, via modem, from all of the major online services such as America Online, Compuserve, E-world, AppleLink, the Internet, as well as from the Radius bulletin board at 408-541-6190.

Q: What are the current versions of the software I need to use a PhotoBooster, and how can I obtain it?

A: You need two files to use PhotoBooster. The first file is a System Extension entitled "•Radius DSP" which should be placed in the Extensions folder of your System folder. The current version of that file is 1.1.1. The second file is a Photoshop Plug-in, entitled "PhotoBooster Plug-in" which should be placed into the folder you are using to contain your Photoshop Plug-ins. The current version of the Plug-in is 1.0. If you do not have the current versions of the necessary software , they can be downloaded via modem from major online services such as America Online, Compuserve, eWorld, AppleLink, the Internet at ftp.radiusvintage.com, and from the Radius bulletin board at 408-541-6190.


Return to Radius Technical Q&A

Comments to support@radius.com